Page 1 of 1

SbS Print Export error

PostPosted: Mon Nov 05, 2012 12:05 pm
by blendtusiast
Hi, I've a serious problem with the Export function of SbS 3D images.
When I select to export SbS in full quality (Print option) the file is always 0 Byte...and it remain blocked from deletion until PB3D is running.
I've tried with numerous images and resolutions, trying also to make a "pancake" flat 3d image and then exporting it in full res...but nothing.
I've reinstalled PB3D too. Nothing.
Exporting as Web/TV (max 1000x1000) actually works and it can be immediately opened in "PhotoStereo Maker" (I use it to create Wiggle 3D images and converting anaglyph in general...as it's also suggested in the manual), but exporting a SbS in print mode produce always 0 byte files.
Renaming the file in the saving section doesn't do anything at all...
Strange thing is that anaglyph red\cyan works in print pretty flawlessly.

Ok, let's go to the specs:
Win7 x64 SP1
nVidia Geforce GT540m 1gb
512 hdd
8gb ram
intel core i5

Re: SbS Print Export error

PostPosted: Tue Nov 06, 2012 10:55 am
by Oscar
I will look at this, it must be something minor - it did work on my computer.

Re: SbS Print Export error

PostPosted: Tue Nov 06, 2012 11:59 am
by blendtusiast
I answered also to the email, but I'll restate it here:
I tried to create many projects changing images sizes and importing formats (jpg, png, bmp)...but everytime I do SbS export with print option selected I get zero bytes files.
I'm going to try on another PC with Win7 x64. I'll post the results.

Re: SbS Print Export error

PostPosted: Tue Nov 06, 2012 12:08 pm
by blendtusiast
Just tried (the PC is on my left desk ) ...same thing.
I created a new project from scratch and tried to export it first without saving it and then saving it as a new file. Nothing: zero bytes file.
Here's the PC:
Win7 x64
4gb ram
320gb hdd
Intel pentium b950 2.10ghz
Intel Hd (gpu obviously)

Very little in common with the other PC apart from Win7 x64.

EDIT: Just tried also on a Vista x32 with Ati gpu and I got the same result.
I downloaded the setup again to check if it was corrupted somehow...but no, zero bytes again, always.
So it's not a win7 x64 related problem...it's not intel gpu based (also if I think there's no use of particular gpu) not a ram one...nor hdd. So definetely not a pc related issue. I'm gonna try it on a xp x32 sp3...but I'm not so positive by now.

EDIT 2: And in fact... win xp x32 sp3, amd cpu, ati gpu...zero bytes file.
I'm tired...later I'll try to inspect why on Earth I'm the only one suffering from this problem. Bye for now.

EDIT 3: Ok...I'm very stubborn ...
I tried to change to extension in the saving process. I mean, when I click on the button to save in sbs (with the print option checked) I type a namefile followed by ".jpg"...and magically the file saves...but as a single image "red-cyan anaglyph" jpg. So, given that I'm a programmer too, I think that the saving process is ruled by a routine that checks the extension selected from the menu in the saving windows. In the anaglyph and web\tv window all goes well...but in the sbs (print) saving window there's a bug that don't see the extension which I chose.
So, giving manually an extension ( I tried with .jpg, .bmp, .png) everytime the program saves correctly in that format (not only the extension is changed but also the file is really a jpg, bmp, png etc.), but when the .jps extension is chosen then PB3D goes in a loop because it can't find the correct option for that format with the print option selected (presumably a missing "If" or "ElseIf"). This could explain why the "zero-byte" file created remains "used by" PB3D until the end of it's execution.
I hope that with this last edit I put you (Oscar) on the right path to fix this bug...because it's all I can do.

Re: SbS Print Export error

PostPosted: Wed Nov 07, 2012 1:31 am
by Oscar
Yes, hopefully the extension would be the culprit, that would be easy fix.
I will have look asap.

Re: SbS Print Export error

PostPosted: Fri Nov 09, 2012 6:38 am
by blendtusiast
Any news?
I actually need that function for a project I'm working on which includes the use of big full-hd screens ...this is why the resolution is so important to me.
I work as a freelance graphic consultant for a local advertising agency and the idea was to use PB3D to make compositions of images where female models are wearing clothes of a local clothing store. And doing that with pb3d, using the same catalogue pictures without recalling the models for stereo photos (and repaying them) is simply amazing. Plus on the background I can put some beautiful natural or urban scape instead of the original white bakground. The stereo output in sbs is optimal to make glasses-free Wiggle (or Wobble) 3d images (displayed on the said screens). The wiggling is very Eye-Catchy but the models remain on zero level with only the background left to wiggle (obviously below the zero level).
All this could be great...if only the full res export will works...

Re: SbS Print Export error

PostPosted: Tue Nov 13, 2012 9:15 pm
by Oscar
First I thought I forgot to implement it - but I did, just called the anaglyph function by mistake instead of the sbs function... so it will be quick. I am just testing it - so far looks it is working.

I uploaded new install: 1.5.1
http://www.mediachance.com/photoblend/index.html

Re: SbS Print Export error

PostPosted: Wed Nov 14, 2012 4:01 am
by blendtusiast
Ok, it's working!
I'm glad you solved it! 8-)
Thank you :D